JCA files are not getting updated with config plans in SOA Suite 12.2.1.0.0

Issue –> While deploying a composite on SOA 12.2.1, when the JCA adapter needs to take the configuration from the deployment plan to deploy correctly but it is failing with the below error.

Error –>

<JCABinding=> [ConfigPlanTest.TestdbReference/1.0] JNDI lookup of ‘eis/DB/TESTSOA_DEV’ failed due to: While trying to lookup ‘eis.DB/TESTSOA_DEV’ didn’t find subcontext ‘eis’. Resolved ”>
Problem 1: [ ]:
The JCA Binding Component is unable to locate the Resource Adapter specified in the element: location=’eis/DB/TESTSOA_DEV’
The reason for this is most likely that either
 1) the Resource Adapters RAR file has not been deployed successfully to the WebLogic J2EE Application server or
 2) the JNDI setting in the WebLogic JCA deployment descriptor has not been set to eis/DB/TESTSOA_DEV. In the last case you might have to add a new ‘connector-factory’ entry (connection) to the deployment descriptor.
Please correct this and then restart the WebLogic Application Server>
<ServletContext-/soa-infra> oracle.fabric.common.FabricException: Deployment Failed: Error while validating JCA Reference Binding meta data during composite deployment. : JCA deployment validation errors for ‘Adapters/TestdbReference_db.jca’   at oracle.integration.platform.blocks.deploy.StandaloneCompositeDeploymentCoordinatorImpl.coordinateCompositeDeployment(StandaloneCompositeDeploymentCoordinatorImpl.java:117)   at  oracle.integration.platform.blocks.deploy.StandaloneCompositeDeploymentCoordinatorImpl.coordinateCompositeDeployment(StandaloneCompositeDeploymentCoordinatorImpl.java:78)   at  oracle.integration.platform.blocks.deploy.servlet.BaseDeployProcessor.deployNewComposite(BaseDeployProcessor.java:614)
  at oracle.integration.platform.blocks.deploy.servlet.BaseDeployProcessor.deploySARs(BaseDeployProcessor.java:369)
  at oracle.integration.platform.blocks.deploy.servlet.BaseDeployProcessor.deploySARs(BaseDeployProcessor.java:184)
  Truncated. see log file for complete stacktrace

Solution –>

This is a BUG in SOA suite 12.2.1.0.0 , for resolving this we need to apply the below patch.

Patch # 22648699

Apply the patch in test instance and test again. If it resolved the issue move it to other environments.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s