Unable to find a WSDL that has a definition for service

Issue –> While deploying a SOA project in Jdeveloper i got the below error.

Error –>

Received HTTP response from the server, response code=500
Error deploying archive sca_myTaxProcess_rev1.0.jar to partition “default” on server soa_server1 [http://localhost:8001] 
HTTP error code returned [500]
Error message from server:
There was an error deploying the composite on soa_server1: Deployment Failed: Unable to find a WSDL that has a definition for service {http://xmlns.oracle.com/soa/soaTaxProcess/TaxRateProcess}TaxRateProcess.service and port TaxProcessPort.  Please make sure that the port attribute for the binding defined in the composite file is correct by checking the namespace, service name, and port name.  In addition, check that the WSDL associated with the binding namespace is imported and currently reachable (check the import nodes at the top of the composite file). Finally, validate the HTTP proxy settings for the server..

Solution –> 

Actually the referenced webservice’s hostname mapping was missing in my “new” environment because of which the SOA composite was unable to find the WSDL during deployment.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s